2006年10月21日土曜日

[Linux] CentOS4 に qpopper をインストールする(APOP版)

[Linux] CentOS4 に qpopper をインストールする」ではPOP3版でしたが、
今度はAPOP版を再インストール。

環境、用意するものはPOP3版と同じ。

��.コンパイル&インストール
$ useradd pop
$ tar zxvf qpopper4.0.9.tar.gz
$ cd qpopper4.0.9
$ ./configure --enable-apop=/etc/pop.auth --with-popuid=pop
$ make
$ cd popper/
$ install popper /usr/local/sbin/
$ install popauth /usr/local/sbin/

��.APOPパスワードDB&ユーザ設定
$ /usr/local/sbin/popauth -init
Really initialize POP authentication DB? y
$ popauth -user isoya9
Adding only APOP password for isoya9.
New password:
Retype new password:

��.動作確認
POP3アクセスするとエラーになる
$telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
+OK Qpopper (version 4.0.9) at hogehoge.com starting.
user isoya9
-ERR [AUTH] You must use stronger authentication such as AUTH or APOP to connect to this server
quit
+OK Pop server at hogehoge.com signing off.
Connection closed by foreign host.

後はAPOPに対応したクライアントメーラでチェック
※Outlook Express はAPOPに対応していないらしいのでご注意
http://www.iij4u.or.jp/guide/basic/mail/mailsoft/


おしまい。

0 件のコメント: